Вопрос по информатике:
Составьте программу, которая по введенному вами K - числу грибов печатает фразу <Мы нашли в лесу K грибов>, причем согласовывает окончание слова <гриб> с числом K. Количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. Окончание фразы определяется значением последней цифры.
- 14.07.2016 23:33
- Информатика
- remove_red_eye 1772
- thumb_up 8
Ответы и объяснения 1
Var g,i:integer;
begin
read(g);
if (g=1) or ((g>20) and (g mod 10=1)) then begin writeln('Мы нашли в лесу ',g,' гриб'); i:=1; end;
if ((g mod 10>1) and (g mod 1021) and (g mod 10>1) and (g mod 10<5)) then begin writeln('Мы нашли в лесу ',g,' гриба'); i:=1; end;
if i=0 then writeln('Мы нашли в лесу ',g,' грибов');
end.
- 15.07.2016 10:20
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.