Вопрос по информатике:
Составить программу нахождения суммы всех нечетных отрицательных элементов массива,образованного случайными числами в диапазоне от -30 до 30(на языке Паскаль)
- 10.11.2017 00:01
- Информатика
- remove_red_eye 9480
- thumb_up 8
Ответы и объяснения 1
Const N = 5;
Var a:array [1..N] of integer; i,S:integer;
Begin
randomize; S:=0;
for i:=1 to N do begin
a[i]:=random(61)-30;
if (a[i]<0) and (a[i] mod 2 0) then S:=S+a[i]; end;
writeln(S);
readln;
end.
- 11.11.2017 06:13
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.