Вопрос по информатике:
Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно).
- 12.08.2017 00:39
- Информатика
- remove_red_eye 3731
- thumb_up 9
Ответы и объяснения 1
Var
i,k,m,j:integer;
a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
a[i]:=random(50);
write(a[i]:3);
end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
begin
b[j]:=a[i];
j:=j-1;
end;
for i:=k to m do a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do write(a[i]:3);
end.
- 13.08.2017 17:14
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.