Вопрос по информатике:
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.
- 18.12.2017 00:28
- Информатика
- remove_red_eye 14065
- thumb_up 43
Ответы и объяснения 1
Program asd;
uses crt;
var n,m,min:integer;
r:real;
begin
Write('Введите число n: ');
Readln(n);
Write('Введите число m: ');
Readln(m);
If n>m then
min:=m
else
min:=n;
If (n>100) and (m>100) then
begin
n:=min;
m:=min;
Writeln('n= ',n,' m= ',m);
end;
If (n>0) and (m<0) then
Writeln('n= ',n/2,' m= ',m/2)
else
r:=(n+m)/2;
Writeln('Среднее арифм. : ',r);
end.
- 19.12.2017 02:07
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.