Вопрос по информатике:
Автоморфные числа
Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата.
Например 25²=625 . Напишите программу,
которая находит все автоморфные числа на отрезке [a , b ] .
Входные данные
Входная строка содержит два натуральных
числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести в одну строчку все
автоморфные числа на отрезке [ a , b ] , разделив их пробелами. Если таких чисел нет,
программа должна вывести число -1.
Примеры
входные данные
20 100
выходные данные
25 76
- 16.03.2018 22:36
- Информатика
- remove_red_eye 4609
- thumb_up 27
Ответы и объяснения 1
Var a, b, a1, i, k, x, q:integer;
begin
readln(a, b);
a1:=a;
k:=0;
while a0 do
begin
a:=a div 10;
k:=k+1;
end;
x:=1;
for i:=1 to k do
x:=x*10;
q:=-1;
for i:=a1 to b do
if i=((i*i) mod x) then
begin
write(i, ' ');
q:=i;
end;
if q=-1 then write(q);
end.
- 17.03.2018 09:04
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.