Вопрос по информатике:
Поставлю лучший, много баллов! Напишите программу в Pascal ABC которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод - REPEAT...UNTIL (в скобках указана размерность массива):
увеличить элементы массива с четными индексами на 1 (11)
- 14.03.2018 06:08
- Информатика
- remove_red_eye 13389
- thumb_up 38
Ответы и объяснения 1
Var a:array[1..11] of integer;
b:integer;
begin
b:=1;
writeln('Введите элементы массива');
while (b<=11) do
begin
readln(a[b]);
if (b mod 2=0) then a[b]:=a[b]+1;
b:=b+1;
end;
b:=1;
repeat
writeln(a[b]);
b:=b+1;
until(b>11)
end.
- 15.03.2018 01:23
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.