Вопрос по информатике:
ПАСКАЛЬ, строка символов
Напишите программу, которая:
а) определяет, сколько раз встречается в строке символ 'A'
б) заменяет символ 'А' символом ' * '
в) удаляет из строки символ 'В'
Пожалуйста, помогите! :с
- 23.11.2017 10:47
- Информатика
- remove_red_eye 15469
- thumb_up 8
Ответы и объяснения 2
А)Program z1;
Var S:string;
i,n,d:integer;
Begin
read(s);
d:=length(s);
n:=o;
For i:=1 to d do
If copy(S,i,1)='A' then
n:=n+1;
writeln(n );
End.
- 24.11.2017 05:32
- thumb_up 40
Program proga;
var str:string;
i,counter,pos:integer;
k:char;
a:array[1..255] of char;
begin
k:='*';
counter:=0;
writeln('Введите строку');
readln(str);
for i:=1 to length(str) do begin
if str[i]='А' then begin
inc(counter);
Delete(str,i,1);
Insert(k,str,i);
end;
end;
writeln('Количество символов А ',counter);
for i:=1 to length(str) do begin
a[i]:=str[i];
if a[i]='В' then
a[i]:=' ';
write(a[i]);
end;
end.
- 25.11.2017 13:30
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.