Вопрос по информатике:
ОЧЕНЬ НУЖНА ПОМОЩЬ ДО ЗАВТРА!!1 ПОМОГИТЕ!!
Напишите эффективную программу, которая по двум данным натуральным числам p и q не превосходящим 30 000, подсчитывает кол-во натуральных чисел с последней цифрой 0 на интервале (p,q) (не включая концы интервала)
Программа получает на вход 2 натуральных числа p и q, при этом гарантируется, что 1≤p<q≤30 000
Проверять входные данные на корректность не нужно.
Программа должна вывести одно число: кол-во натуральных чисел с последней цифрой 0 на отрезке (p,q)
- 06.09.2017 18:54
- Информатика
- remove_red_eye 4410
- thumb_up 7
Ответы и объяснения 1
Код программы для С#. Думаю при желании можно запросто переписать на любой другой язык программирования.
Console.WriteLine("Введите p");
double p = Convert.ToInt16(Console.ReadLine());
Console.WriteLine("Введите q");
double q = Convert.ToInt16(Console.ReadLine());
int c = 0;
double x = 0;
for (double i = p + 1; i < q - 1; i++) { x = i % 10; if (x == 0) c++; }
Console.WriteLine("----------------");
Console.WriteLine("Количество натуральных чисел с последней цифрой 0 на отрезке (p,q) = "+ c);
Console.ReadLine();
При желании могу скинуть уже готовую программу.
- 08.09.2017 00:43
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.