Вопрос по информатике:
Семьдесят два балла за простое задание! Сделайте по-нормальному, пожалуйста.
Написать программу для вычисления корней квадратного уравнения: ax^2+bc+c=0.
- 17.04.2015 12:30
- Информатика
- remove_red_eye 16423
- thumb_up 17
Ответы и объяснения 1
Var a,b,c,d,x1,x2:real;
begin
writeln('Введите коэффициент a');
readln(a);
writeln('Введите коэффициент b');
readln(b);
writeln('Введите коэффициент c');
readln(c);
d:=sqr(b)-4*a*c;
if d>0 then
begin
x1:= ((-1)*b+sqrt(d))/(2*a);
x2:=((-1)*b-sqrt(d))/(2*a);
writeln('x1=',x1,' x2=',x2);
end
else if d=0 then
begin
x1:= ((-1)*b)/(2*a);
writeln('x=',x1);
end
else writeln('Корней нет');
end.
- 18.04.2015 19:23
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.