Вопрос по информатике:
Составьте программу, вычисляющую для двух дробей a/b и c/d (a,b,c,d - натуральные числа):
деление
умножение
сложение.
Результат представить в виде простых несократимых дробей
В виде функции.
Pascal
- 10.09.2016 15:30
- Информатика
- remove_red_eye 607
- thumb_up 37
Ответы и объяснения 1
Как-то так)
var a,b,c,d,e,f:integer;
function nod(m,n:integer):integer;
begin
while mn do
if m>n then m:=m-n
else n:=n-m;
nod:=m
end;
begin
write('введите числитель1, знаменатель1, числитель2, знаменатель2');
readln(a,b,c,d);
e:=a*d+b*c;
f:=b*d;
if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('сложение = ',e)
else begin
e:=e div nod(abs(e),f);
f:=f div nod(abs(e),f);
writeln('сложение = ',e,'\',f);
end;
e:=a*c;
f:=b*d;
if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('умножение = ',e)
else begin
e:=e div nod(abs(e),f);
f:=f div nod(abs(e),f);
writeln('умножение = ',e,'\',f);
end;
e:=a*d;
f:=b*c;
if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('деление= ',e)
else begin e:=e div nod(abs(e),f);
f:=f div nod(abs(e),f);
writeln('деление = ',e,'\',f);
end;
end.
- 11.09.2016 02:21
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.