Вопрос по информатике:
Напишите программу, которая выбирает максимальное и минимальное из пяти введённых
чисел. (c++)
Найдите ошибку в программе:
k = 0; while ( k < 10 )
printf ( "привет\n" );
k=0;
while ( k < 10 ) cout <<
"привет"
<< endl;
Как её можно исправить?
- 08.04.2018 05:21
- Информатика
- remove_red_eye 6593
- thumb_up 23
Ответы и объяснения 1
Напишите программу, которая выбирает максимальное и минимальное из пяти введённых
чисел. (c++)
#include
int main()
{
double max = 0.0;
while(std::cin) // Ввод пока не произойдет прерываение сочетанием cntr+z (в windows)
{
double t = 0.0;
std::cin >> t;
if(t > max) max = t;
} std::cout << "Max: " << max;
}
- 09.04.2018 03:01
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.