Вопрос по информатике:
Генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с помощью которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами.
- 08.10.2017 14:15
- Информатика
- remove_red_eye 607
- thumb_up 9
Ответы и объяснения 2
Const n = 20;
var a :array [1..n] of integer; i, sum :integer;
begin
randomize; for i:= 1 to n do a[i]:= random(100); for i:= 1 to n do write(a[i],' '); writeln; sum:= 0; for i:= 1 to n do if i mod 2 = 1 then sum:= sum + sqr(a[i]); writeln(sum);
end.
- 01.01.1970 00:00
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.