Вопрос по информатике:
Помогите пожалуйста!! паскаль
Входными данными являются число k, N и N целых чисел.
В массиве определить индекс k-го наибольшего элемента массива.
Считать, что все элементы разные.
Ограничения:
Считать, что все элементы разные.
N принимает значения от 1 до 20.
k принимает значения от 1 до N.
Формат входных данных:
k, N и N целых чисел
Формат выходных данных:
индекс второго наибольшего элемента массива
- 22.11.2016 12:54
- Информатика
- remove_red_eye 15590
- thumb_up 43
Ответы и объяснения 1
Var
i,j,n,k: integer;
a,b:array[1..20]of integer;
begin
writeln('Введите N');
readln(n);
for i:=1 to n do
begin
readln(a[i]);
b[i]:=a[i];
end;
for i:=1 to n do
for j:=1 to n do
if b[i]>b[j] then
begin
k:=b[i];
b[i]:=b[j];
b[j]:=k
end;
for i:=1 to n do
if a[i]=b[2] then k:=i;
writeln('k=',k);
end.
- 23.11.2016 03:52
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.