Вопрос по информатике:
Помогите написать программу в паскале:Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не имеет.
(например
a) S1=’april’, S2=’may’. Ответ: false
b) S1=’Rom’, S2=’room’. Ответ: false, т.к. буква ‘o’ встречается в строке S1 один раз.
c) S1=’tomorrow’, S2=’mOtOr’. Ответ: true)
- 26.10.2017 08:12
- Информатика
- remove_red_eye 12809
- thumb_up 21
Ответы и объяснения 1
Var
i,n:integer;
s1,s2:string;
f:boolean;
begin
f:=true;
writeln('Введите первую строку');
readln(s1);
writeln('Введите вторую строку');
readln(s2);
s1:=LowerCase(s1);
s2:=LowerCase(s2);
i:=1;
repeat
n:=pos(s2[i],s1);
if n>0 then delete(s1,n,1) else f:=false;
i:=i+1;
until i=length(s2);
writeln(f)
end.
- 27.10.2017 07:21
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.