Вопрос по информатике:
Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе
- 25.01.2018 02:44
- Информатика
- remove_red_eye 18504
- thumb_up 14
Ответы и объяснения 1
uses crt;
type uchenik=record
fam:string[20];
im:string[20];
kls:string[3];
end;
var a:array[1..100] of uchenik;
n,i,j,k:byte;
begin
clrscr;
writeln('Сколько учеников n=');
readln(n);
writeln('Введите данные о ',n,' учениках:');
for i:=1 to n do
begin writeln('Ученик ',i);
write(' Фамилия: ');
readln(a[i].fam);
write(' Имя: ');
readln(a[i].im);
write(' Класс ( год+буква, 11а): ');
readln(a[i].kls);
end;
writeln('Однофамильцы в одном классе:');
k:=0; for i:=1 to n-1 do for j:=i+1 to n do
if (a[i].fam=a[j].fam)and(a[i].kls=a[j].kls) then
begin
k:=1;
writeln(a[i].kls,' ',a[i].fam,' ',a[i].im,' ',a[j].fam,' ',a[j].im);
end;
if k=0 then write('Однофамильцев в одном классе нет!');
readln
end.
- 26.01.2018 03:16
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.