Вопрос по информатике:
Написать программу которая классифицирует треугольники равнобедренный, равносторонний,прямоугольный,если даны 3 стороны треугольника.
- 20.08.2017 23:34
- Информатика
- remove_red_eye 18626
- thumb_up 10
Ответы и объяснения 1
Var a,b,c:real;
begin
writeln('Введите 1 сторону треугольника');
readln(a);
writeln('Введите 2 сторону треугольника');
readln(b);
writeln('Введите 3 сторону треугольника');
readln(c);
if (a=b)and(b=c) then writeln('Равносторонний треугольник')
else if (a=b) or(b=c)or(a=c) then writeln('Равнобедренный треугольник')
else if (sqr(a)=sqr(b)+sqr(c))or(sqr(b)=sqr(a)+sqr(c))or(sqr(c)=sqr(b)+sqr(a)) then writeln('Прямоугольный треугольник')
else writeln('Обычный треугольник');
end.
- 21.08.2017 11:39
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.