Вопрос по информатике:
1.Напишите программу, которая в последовательности натуральных чисел
определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.
2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.
- 10.02.2015 20:34
- Информатика
- remove_red_eye 6719
- thumb_up 40
Ответы и объяснения 1
1)var i,x,n,a:integer
begin
x:=0;
read(n);
for i:=1 to n do //Если количество чисел не дано, то надо писать while not eof.
begin
read(a);
if a mod 4 = 0 then inc(x) //x:=x+1;
end;
write(x);
end.
2)var i,min,a,n:integer;
begin
min:=30001;
read(n);
for i:=1 to n do begin
read(a);
if a mod 3 = 0 then
if a
write(min);
end.
В компиляторе не проверял. Удачи.
- 11.02.2015 14:43
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.