Вопрос по информатике:
Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8
- 16.10.2017 09:49
- Информатика
- remove_red_eye 2670
- thumb_up 7
Ответы и объяснения 1
Выше решение не для матрицы 8х8, а для одномерного массива из 5-ти элементов. Вот для двухмерной матрицы 8х8:
const n=8;
var a:array[1..n,1..n] of integer;
i,j,s:integer; sr:real;
begin
for i:=1 to n do
for j:=1 to n do a[i,j]:=random(50)-20;
for i:=1 to n do begin
for j:=1 to n do write(a[i,j]:4);
writeln;
end;
writeln;
sr:=0; s:=0;
for i:=1 to n do
for j:=1 to n do
s:=s+a[i,j];
sr:=s/sqr(n);
write('среднее арифметическое всех элементов матрицы = ',sr);
end.
- 17.10.2017 02:15
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.