Вопрос по информатике:
Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент. Протестировать программу на массивах размерностью 8 и 10 элементов.
- 11.02.2018 09:52
- Информатика
- remove_red_eye 13073
- thumb_up 41
Ответы и объяснения 1
Program z1;
var a:array[1..100] of integer;
n,i:byte;ma:integer;
begin
write('n=');readln(n);
for i:=1 to n do begin
write(i,')');readln(a[i])
end;
ma:=a[1];
for i:=1 to n do begin
if a[i]>ma then begin
ma:=a[i]
end
end;
for i:=1 to n do begin
a[i]:=ma
end;
writeln('test n=',n);
for i:=1 to n do begin
writeln(a[i])
end;
readln
end.
- 12.02.2018 12:29
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.