Вопрос по информатике:
Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен произведению соответствующего элемента исходного массива и заданного с клавиатуры числа А. В проученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные полученные результаты.
- 01.02.2016 12:16
- Информатика
- remove_red_eye 1228
- thumb_up 19
Ответы и объяснения 1
Var
m,n: array [1..15] of integer;
a,i,max: integer;
begin
readln(a);
writeln('Исходный массив:');
for i:= 1 to 15 do
begin
m[i]:= random(20);
n[i]:=m[i]*a;
if (n[i]>max) and (i mod 2=1) then max:=n[i];
write (m[i],' ');
end;
writeln;
writeln('Новый массив:');
for i:= 1 to 15 do write (n[i],' ');
writeln;
writeln('Максимальный нечетный: ',max);
end.
- 02.02.2016 22:19
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.