Вопрос по информатике:
Cоставить алгоритм и написать программу.
Найдите дискриминант квадратного уравнения:y=5x^2+6x-7
- 06.08.2018 19:03
- Информатика
- remove_red_eye 5863
- thumb_up 48
Ответы и объяснения 1
#include
#include
using namespace std;
int main()
{
float a,b,c;
int d;
float x1, x2;
cout << "ax^2+bx+c=0" << endl;
cout << "Input a:" << endl;
cin >> a;
cout << "Input b:" << endl;
cin >> b;
cout << "Input c:" << endl;
cin >> c;
d= sqrt(b*b-4*a*c);
x1=((-1)*b+d)/(2*a);
x2=((-1)*b-d)/(2*a);
cout << "x1=" << x1 << endl;
cout << "x2=" << x2 << endl;
return 0;
}
Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
- 07.08.2018 11:47
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.