Вопрос по информатике:
В Pascal ABC составить программу для подсчета четных цифр, используемых для записи произвольного числа X.
использовать цикл с предусловием, другого не проходили
ОЧЕНЬ СРОЧНО ПОЖАЛУЙСТА!!!!!
- 08.12.2015 23:28
- Информатика
- remove_red_eye 16647
- thumb_up 48
Ответы и объяснения 1
Program red;
var a,b:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a mod 2=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10) mod 2=0) and (a div 10 0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10 0) then b:=b+1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100) mod 2=0) and (a div 100 0) then b:=b+1;
if (((a div 10) mod 10) mod 2=0) and ((a div 10) mod 10 0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 100) then b:=b+1;
end;
writeln(b);
end.
- 09.12.2015 23:47
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.