Вопрос по информатике:
Составить программу Плиз, в среде PASCAL ABC (TURBO PASCAL) выполняющую вычисления по формуле:
y=2ctg3x-
- 08.02.2015 09:21
- Информатика
- remove_red_eye 10603
- thumb_up 30
Ответы и объяснения 2
Паскаль авс:
Program Ikiru;
uses crt;
var
y,x:real;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln(); writeln();
write('Введите Х '); readln(x);
if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
then
writeln('Функция Y для этого значения Х не определена')
else
begin
y:=2*(cos(3*x)/sin(3*x))-ln(cos(x))/ln(1+x*x);
writeln('y=',y:8:2);
end;
end.
Пояснения:
write('Введите Х '); readln(x);
- программа просит пользователя ввести х
if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
- проверка существования функции (функция ctgХ не существует, если sinX=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0)
Если хотя бы одно из условий не выполняется, выводится ссобщение о том, что функция для этого значения не определена.
Если все проверки пройдены, программа вычисляет значение функции Y и выводит его на экран.
- 01.01.1970 00:00
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.