Вопрос по информатике:
Написать программу, которая проверяет – имеется ли в записи натурального числа ноль.
Язык программирования паскаль.
- 06.09.2015 20:03
- Информатика
- remove_red_eye 11304
- thumb_up 25
Ответы и объяснения 1
Program red;
var a,b,c:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a*5=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10)*5=0) then b:=1;
if ((a mod 10)*5=0) then b:=1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100)*5=0) then b:=1;
if (((a div 10) mod 10)*5=0)then b:=1;
if ((a mod 10)*5=0)then b:=1;
end;
if b=1 then writeln('yes') else writeln('no');
end.
- 07.09.2015 16:16
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.