Вопрос по информатике:
Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел было введено. Описание переменных: q - счетчик простых чисел; n - очередное введенное число. Алгоритм решения задачи: Пока введенное число больше 1, проверять его на простоту по следующему алгоритму: Если число делится на любой делитель от 2 до половины от себя, то оно не простое. Если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.
- 19.06.2016 23:17
- Информатика
- remove_red_eye 19920
- thumb_up 49
Ответы и объяснения 1
Var q,n,i,k,h:integer;
begin
readln(n);
h:=1;
while n>1 do
begin
k:=n div 2;
for i:=2 to k do
if n mod i=0 then h:=0;
q:=q+h;
h:=1;
readln(n);
end;
writeln('Простых чисел: ',q)
end.
- 20.06.2016 10:43
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.