Вопрос по информатике:
Пожалуйста,помогите решить задачи на Pascale!
1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"
- 15.02.2018 04:11
- Информатика
- remove_red_eye 16619
- thumb_up 31
Ответы и объяснения 1
Const n=7; m=8;
Var a:array[1..n,1..m] of integer;
i,j,x,y,min:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write(a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
x:=1;
y:=1;
for i:=1 to n do
for j;=1 to m do
if a[i,j]
x:=i;
y:=j;
end;
writeln ('минимальный элемент=',min,' он находился: ',x,',',y);
a[x,y]:=100;
for i:=1 to n do begin
for j:=1 to n do
write (a[i,j]:4);
writeln;
end;
end.
3.Var s:string;
i:integer;
begin
writeln('Введи строку');
readln (s);
for i:=1 to length(s) do
if (s[i]='Е') or (s[i]='е') then delete(s,i,1);
writeln(s);
end.
- 16.02.2018 01:57
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.