Вопрос по информатике:
С ПОМОЩЬЮ ПАСКАЛЯ
1.Найти сумму всех нечётных трёхзначных чисел.
2. Дано натуральное число n.
Сколько цифр в числе n?
3. Старинная задача. Сколько можно купить быков, коров и телят, если бык стоит 10 рублей, корова – 5 рублей, телёнок – полтинник (0,5 рубля), при условии, что на 100 рублей надо купить 100 голов скота.
- 14.06.2018 00:31
- Информатика
- remove_red_eye 10940
- thumb_up 22
Ответы и объяснения 1
Var i,s:integer;
begin
i:=101;
while i<1000 do
begin
s:=s+i;
i:=i+2
end;
writeln('Ответ: ',s)
end.
var n,x:integer;
begin
write('Введите число: ');
readln(n);
while n>0 do
begin
n:=n div 10;
x:=x+1
end;
writeln('Цифр: ',x)
end.
var x,y,z:integer;
begin
for x:=0 to 100 do
for y:=0 to 100 do
for z:=0 to 100 do
if (x+y+z=100) and (10*x+5*y+0.5*z=100) then
writeln('быков:',x,' коров:',y,' телят:',z);
end.
- 15.06.2018 07:43
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.