Вопрос по информатике:
Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во время работы программы. (цикл для)(паскаль )
- 24.12.2017 11:25
- Информатика
- remove_red_eye 14606
- thumb_up 14
Ответы и объяснения 2
Var
i, count : integer;
summ, temp : real;
begin
summ := 0;
readln(count);
for i := 1 to count do
begin
readln(temp);
summ := summ + temp;
end;
writeln(summ / count);
end.
- 25.12.2017 12:25
- thumb_up 35
Program Nooobodyyy;
uses crt;
var
i,how:integer;
ch,appr,sum:real;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln(); writeln();
writeln('Программа запрашивает N дробных чисел и находит их среднее арифметическое');
sum:=0;
write('Введите количество чисел: '); readln(how);
for i:=1 to how do
begin
write('Введите ',i,'-e число: '); read(ch);
sum:=sum+ch;
end;
appr:=sum/how;
writeln('Cреднее арифметическое равно ',appr:8:2);
end.
- 26.12.2017 09:04
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.