Вопрос по информатике:
С ПОМОЩЬЮ ПАСКАЛЯ
Дана информация о температуре воздуха за январь. Написать программу, которая:
а)Определит сколько раз температура опускалась ниже 0 градусов
б)Определит среднюю температуру за январь
- 13.07.2018 16:56
- Информатика
- remove_red_eye 9245
- thumb_up 13
Ответы и объяснения 1
Var
st:real;
i,n:integer;
t:array[1..31]of integer;
begin
writeln('Температура в январе:');
for i:=1 to 31 do
begin t[i]:=random(-10,5);
write(t[i],' ');
st:=st+t[i];
if t[i]<0 then n:=n+1
end;
st:=st/31;
writeln;
writeln('Число дней с отр.температурой: ',n);
writeln('Средняя температура: ',st:1:1)
end.
- 14.07.2018 04:49
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.