Вопрос по информатике:
Напишите эффективную программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество натуральных чисел, кратных числу a, на отрезке [a,b] (включая концы отрезка). Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1≤a≤b≤30000. Программа должна вывести одно число: количество натуральных чисел кратных числу a на отрезке [a,b]
- 23.10.2017 00:27
- Информатика
- remove_red_eye 7960
- thumb_up 30
Ответы и объяснения 1
Var a,b,i,k:integer;
begin
readln(a);
readln(b);
k:=0;
if (a>b) or (b>30000) or (a<1) then writeln('данные введены некорректно') else begin
for i:=a to b do
if i mod a=0 then k:=k+1;
writeln(k);end;end.
- 23.10.2017 11:52
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.