Вопрос по информатике:
Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу определяющую победителя после N бросков.
- 04.04.2018 12:42
- Информатика
- remove_red_eye 3789
- thumb_up 15
Ответы и объяснения 1
Var n, i, sum1, sum2, buf: integer;
begin
writeln('Введите количество бросков');
readln(n);
sum1 := 0;
sum2 := 0;
i := 0;
for i := 1 to n do
begin
writeln('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени А ');
readln(buf);
sum1 := sum1 + buf;
end;
for i := 1 to n do
begin
writeln('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени B');
readln(buf);
sum2 := sum2 + buf;
end;
if sum1 = sum2 then writeln('Ничья') else
if sum1 > sum2 then writeln('Победил человек по имени А')
else writeln('Победил человек по имени B');
end.
Как то так ...
- 05.04.2018 12:53
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.