Вопрос по информатике:
Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия:
а) Четные числа делит на 2 и результат выводит на экран
б) нечетные числа выводит на экран без изменений
- 21.05.2016 14:57
- Информатика
- remove_red_eye 15900
- thumb_up 28
Ответы и объяснения 1
Var a,b,c:integer;
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.
- 22.05.2016 11:57
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.