Вопрос по информатике:
Составить программу, которая упорядочивает элементы четных строк по возрастанию,а нечетных по убыванию.Матрица размером 8х8.Полученную матрицу напечатать.
- 17.06.2018 00:00
- Информатика
- remove_red_eye 11482
- thumb_up 51
Ответы и объяснения 1
Var
i,j,k,p:integer;
a:array[1..8,1..8]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 8 do
begin
for j:=1 to 8 do
begin
a[i,j]:=random(20);
write(a[i,j]:3)
end;
writeln
end;
for i:= 1 to 8 do
for j:= 1 to 8 do
for k:= 1 to 8 do
begin
if i mod 2=0 then
begin
if (a[i,j] begin
p:=a[i,j];
a[i,j] := a[i,k];
a[i,k] := p
end
end
else
if a[i,j] > a[i,k] then
begin
p:=a[i,j];
a[i,j] := a[i,k];
a[i,k] := p
end
end;
writeln('Преобразованный массив:');
for i:=1 to 8 do
begin
for j:=1 to 8 do
write(a[i,j]:3);
writeln
end;
end.
- 19.06.2018 00:19
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.