Вопрос по информатике:
4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. Напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a;b), или 0 в противном случае
- 04.11.2017 11:13
- Информатика
- remove_red_eye 7441
- thumb_up 19
Ответы и объяснения 1
1.
var a,b,r,s:integer;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите остатки r и s: ');
readln(r,s);
if (a mod b=r) or (a mod b=s) then writeln('Да, верно')
else writeln('Нет, неверно')
end.
2.
var a,b,x:real;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите x: ');
readln(x);
if (a<=x) and (x<=b) then writeln(1)
else writeln(0)
end.
- 05.11.2017 06:57
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.