Вопрос по информатике:
Pascal !! Помогите пожалуйста)
Надо составить программу в Паскале, где в двумерном массиве вычисляется количество нулей на главной диагонали.
Завтра сдавать надо( В интернете не нашла ничего толкового..
- 13.07.2018 00:18
- Информатика
- remove_red_eye 2169
- thumb_up 51
Ответы и объяснения 2
Var
i,j,s:integer;
a:array[1..10,1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
for j:=1 to 10 do
begin
a[i,j]:=random(-10,10);
if (a[i,j]=0) and (i=j) then s:=s+1;
write(a[i,j]:3)
end;
writeln
end;
writeln('Число нулей на главной диагонали: ',s)
end.
- 14.07.2018 11:38
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.