Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА!
1. Определите, в норме ли вес обследуемого пациента (нормой
считается вес, равный (рост(см) - 100) ± 5 кг).
Значения роста и веса должны вводиться с клавиатуры, результат выводиться на
экран в виде одного из следующих сообщений: “вес ниже нормы”, “вес в норме”,
“избыточный вес”.
2. Составьте программу, которая моделирует работу простейшего
калькулятора: позволяет ввести первое число, знак операции (+,-,*,/) и второе
число, после чего выводит результат в виде:
<1-е число><знак
операции><2-е число>=<результат>
Или
<1-е число><знак
операции><2-е число> не может быть вычислено
3. Вычислите значение функции по заданному значению аргумента:
- 02.12.2017 01:17
- Информатика
- remove_red_eye 15457
- thumb_up 22
Ответы и объяснения 1
1.Var a,b:integer;
begin
writeln ('введи вес в кг и рост в см');
Readln (a,b);
if (b-100=a+5) or (b-100=a-5) then writeln ('вес в норме')
Else if (b-100>a+5) then writeln ('Вес выше нормы')
else writeln ('вес ниже нормы');
end.
2. Var a,b:integer;
s:real;
s1:char;
begin
writeln ('введи 1-ое число:');
readln (a);
writeln ('введи операцию +,-,/,*');
readln (s1);
writeln ('введи 2-ое число:');
readln (b);
write (a,s1,b);
if s1='*' then Writeln ('=',a*b) else
if s1='-' then writeln ('=',a-b) else
if s1='+' then writeln ('=',a+b) else
if (s1='/') and (b0) then begin
s:=a/b;
if a mod b=0 then writeln ('=',s:1:0)
else writeln ('=',s:5:4);
end
else writeln (' не может быть вычислено');
end.
3. Var x:integer;
y:real;
begin
writeln ('введи х из интервала (-10;15] ');
readln (x);
if (x>-10) and (x<=15) then
begin
if (x>-10) and (x<-4) then y:=sqr(x)
else if (x>=-4) and (x<=7) then y:=1/(2+x)
else y:=sqrt(x);
writeln (y:1:2);
end
else writeln ('х не идентифицирован');
end.
- 03.12.2017 07:22
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.