Вопрос по информатике:
Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран:
а)количество считанных десятичных цифр;
б)количество четных цифр;
в)количество нечетных цифр;
- 06.01.2018 19:43
- Информатика
- remove_red_eye 13165
- thumb_up 38
Ответы и объяснения 1
Var
i,n,x,y,z:integer;
s:string;
begin
readln(s);
for i:=1 to length(s) do
if (47
n:=StrToInt(s[i]);
case n of 0..9:
begin
x:=x+1;
if n mod 2=0 then y:=y+1 else z:=z+1
end
end
end;
writeln('Число цифр: ',x,'; четных цифр: ',y,'; нечетных цифр: ',z)
end.
- 08.01.2018 00:25
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.