Вопрос по информатике:
С клавиатуры вводится произвольное количество чисел N. Определите количество (К) и сумму (S) положительных чисел, оканчивающихся на 6.
Напишите скрипт пожалуйста
- 15.10.2015 07:47
- Информатика
- remove_red_eye 7649
- thumb_up 20
Ответы и объяснения 1
Var n,k,s:integer;
begin
Writeln ('вводи числа, по окончанию введи 9999');
while n<9999 do
begin
readln (n);
if (n>0) and (n mod 10=6) then
begin
inc(k);
s:=s+n;
end;
end;
writeln ('кол-во=',k);
writeln ('сумма=',s);
end.
- 16.10.2015 03:07
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.