Вопрос по информатике:
Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный.
- 14.02.2018 13:53
- Информатика
- remove_red_eye 18614
- thumb_up 45
Ответы и объяснения 2
Var
n,x:string;
i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.
или можно так:
var
n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
- 15.02.2018 11:07
- thumb_up 6
Var a, N: integer;
begin
writeln('Введите число');
readln(N); a:=0;
while N>0 do begin
a:=a*10+N mod 10;
N:=N div 10;
end;
writeln (a);
readln;
end.
- 16.02.2018 16:03
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.