Вопрос по информатике:
Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
- 24.09.2018 17:45
- Информатика
- remove_red_eye 3886
- thumb_up 26
Ответы и объяснения 1
Var
x,max:real;
n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
begin
write('Введите число ',i,': ');
readln(x);
if x<0 then
begin
if max=0 then max:=x; // если это первое отр.число
if x>max then max:=x
end
end;
writeln('Наибольшее среди отрицательных: ',max)
end.
- 25.09.2018 16:48
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.