Вопрос по информатике:
Требовалось
написать программу, которая вводит с клавиатуры координаты точки на плоскости
(x, y – действительные числа) и определяет принадлежность точки заштрихованной
области, включая ее границы. Программист торопился и написал программу
неправильно. Вот она:
var x, y: real;
begin
readln(x, y);
if y>=x then
if y>=0 then
if y<=2-x*x then
write ('принадлежит')
else
write ('не принадлежит')
end
укажите, как нужно доработать программу, чтобы не было случаев неправильной работы. Это можно сделать несколькими способами. Можно указать любой способ доработки исправленной программы
- 15.09.2016 23:20
- Информатика
- remove_red_eye 19289
- thumb_up 6
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.