Вопрос по информатике:
Составьте программу печати таблицы температур по цельсию от 0 до градусов с шагом в один градус и их эквивалентов по шкале фаренгейта используя для перевода формулу tF=9tc/5+32
- 20.01.2018 02:26
- Информатика
- remove_red_eye 14776
- thumb_up 49
Ответы и объяснения 1
var
max, i: integer;
begin
readln(max);
for i := 0 to max do
writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.
Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
- 21.01.2018 08:44
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.