Вопрос по информатике:
Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя процедуру
- 19.06.2018 18:19
- Информатика
- remove_red_eye 7748
- thumb_up 23
Ответы и объяснения 1
Var i,x,k,s:integer;
function Sum(x:integer):integer;
var
t:string;
i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;
function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;
begin
for i:=1 to 5 do
begin
write('Введите число ',i,': ');
readln(x);
k:=Kol(x);
s:=Sum(x);
writeln('Количество цифр ',k,'; сумма цифр ',s)
end
end.
- 20.06.2018 09:40
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.