Вопрос по информатике:
Составить программу расчета нормы внесения известкового удобрения (т/га) по формуле:
Д=_______100* Н__________, где Н- полная норма CaCO3 т/га, В- влажность
(100- В)*(100-К)*П
извести, %; К- количество недеятельных частиц%; П- нейтрализующая способность СаСО3,%.
полная норма СаСО3 изменяется в пределах от 2 до 4 т/га с шагом 0,1 т/га.
- 22.09.2017 03:40
- Информатика
- remove_red_eye 12529
- thumb_up 22
Ответы и объяснения 1
Var h,b,k,p,d:real;
begin
write('Введите В, К, П:');
readln(b,k,p);
writeln(' H','Д':8);
h:=2;
repeat
d:=100*h/(100-b)/(100-k)/p;
writeln(h:1:1,d:10:3);
h:=h+0.1
until h>4.0001 {Вообще-то здесь ровно 4 надо написать, но у меня тогда значение 4 не просчитывается, хотя должно бы}
end.
- 23.09.2017 00:39
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.