Вопрос по информатике:
Помогите написать программу в Паскале и блок-сxему.
Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.
- 16.06.2018 23:15
- Информатика
- remove_red_eye 7721
- thumb_up 6
Ответы и объяснения 1
Var a,b,i: real;
begin
b:=0,5;
for i = 1 to 10 do
begin
readln (a);
if a<0 then
writeln (a)
else
a:=a-b;
writeln (a);
end;
end.
- 18.06.2018 00:41
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.