Вопрос по информатике:
ПОМОГИТЕ! ТОЛЬКО НУЖНО РЕШИТЬ НЕ ЧЕРЕЗ if, A ЧЕРЕЗ CASE1. Пользователь вводит неотрицательное однозначное число A. Написать программу:
вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.
- 19.08.2016 00:42
- Информатика
- remove_red_eye 18560
- thumb_up 30
Ответы и объяснения 1
Var a:integer;
s:real;
begin
readln(a);
case a of
1: begin s:=pi*a*a; writeln(s); end;
2: begin s:=a*a; writeln(s); end;
3: begin s:=a*a*sqrt(3)/4; writeln(s); end;
else writeln('нужно ввести число 1, 2, 3');
end;
end.
- 19.08.2016 15:58
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.