Вопрос по информатике:
Составить программу на паскале.Вычислить корни квадратного
уравнения, заданного коэффициентами A, B,
C (предполагается, что а<>0 и что дискриминант
уравнения неотрицателен)
- 12.05.2016 00:27
- Информатика
- remove_red_eye 19756
- thumb_up 19
Ответы и объяснения 1
Var a,b,c,D,x1,x2:real;
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c;
if D>0 then
begin
x1:=(-b-sqrt(D))/2/a;
x2:=(-b+sqrt(D))/2/a;
writeln('Два корня: ',x1,' и ',x2)
end;
if D=0 then
begin
x1:=-b/2/a;
writeln('Один корень: ',x1)
end;
if D<0 then writeln('Корней нет')
end.
- 13.05.2016 20:05
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.