Вопрос по информатике:
Начав тренировки,спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.
- 27.05.2015 19:54
- Информатика
- remove_red_eye 7447
- thumb_up 11
Ответы и объяснения 2
Var
d:integer;
n,s:real;
begin
n:=10;
s:=10; {путь в первый день, считать будем поэтому со второго дня}
d:=2;
repeat
n:=n*(1+0.1);
s:=s+n;
d:=d+1;
until d>7;
writeln(s)
end.
- 28.05.2015 12:24
- thumb_up 1
Program pr; var norma,total:real;day:integer; begin norma:=10; day:=0; repeat day:=day+1; writeln('День: ',day); writeln('Норма: ',norma:0:1,' км'); writeln(); total:=total+norma; norma:=norma*1.1; until day=7; writeln(); writeln('Всего: ',total:0:1); end.
- 29.05.2015 13:28
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.