Вопрос по информатике:
Составить программу в Паскале:
Найти наибольшее целое n такое что :
a) 3n^4-730n<5
b) e^n-1000Ln*n<=10
- 14.06.2016 14:57
- Информатика
- remove_red_eye 7703
- thumb_up 15
Ответы и объяснения 1
1) Если использовать последний Паскаль АВС, который умеет вычислять степень (Power), то вот вариант программы:
var
n:integer;
s:real; {вообще, он целый, но мой компилятор не пропускает, почему-то считает, что результат вычислений будет real}
begins:=0;
n:=1;
while s<5 do
begin
s:=3*power(n,4)-730*n; {для старого Паскаля напиши так: s:=3*sqr(sqr(n))-730*n}
n:=n+1
end;
writeln(n)
end.
2)
var n,s:real;
begin
s:=0;
n:=1;
while s<=10 do
begin
s:=exp(n)-1000*Ln(n);
n:=n+1
end;
writeln(n)
end.
- 15.06.2016 23:09
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.