Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное чётное число.
- 22.09.2018 04:11
- Информатика
- remove_red_eye 7316
- thumb_up 50
Ответы и объяснения 1
I, k, m, min, max:integer;
a, b:array[1..30000] of integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
max:=a[1];
for i:=1 to n do
if min>a[i] then min:=a[i];
k:=1;
for i:=1 to n do
if ((a[i] mod 2)=0) then begin b[k]:=a[i]; k:=k+1; end;
max:=b[1];
for i:=1 to k do
if max>b[i] then max:=b[i];
writeln(min, ' ', max);
readln;
end.
- 23.09.2018 18:35
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.